Annex pages at the beginning of the document

  • 107 Views
  • Last Post 24 February 2020
jirkamat posted this 08 February 2020

Is it possible to detect annex pages at the beginning of the document in FlexiCapture?

I have annex pages both at the beginning and in the end of the document (varying count of annex pages). At the end of document, I enabled annex pages and it works very well.

But pages before the first one are identified as "unknown document".

I am using FlexiLayout and it works well with searching the Header and Footer.

Order By: Standard | Newest | Votes
Rahul Kapoor posted this 09 February 2020

I have 2 methods in mind to achieve this:

Method 1: If the annex pages have some text in common then look for an identifier and create a custom Annex document definition which will not export anything. So, all the annex pages will match to this annex document definition.

 

Method 2: If there is nothing on the annex page that we can pre-define, create an annex document definition with blank region, this will match to every document. Then in project setup, put this annex document definition after your main document definition in order. So, by doing this, anything that is not matched with your main document definition will get matched to your annex document definition.

jirkamat posted this 09 February 2020

Thanks. My annex pages actually does not have anything in common, so I went with Method 2. I have tried it, but it didn't work, the batch contains the "unrecognized document". I think it's because my main document definition is FlexiLayout that gets applied after all fixed document definitions.

But I turned off Annex pages even in my main document definition and now it's somehow isolated at least - my results are clearly visible among the leading and ending "unkown" documents in the Working Batches. Not ideal, but it will work.

Rahul Kapoor posted this 09 February 2020

You can keep a Required Element in your main document definitions so that id doesn't gets matched to any annex document. Also, your create document property should be "Automatically when document definition is applied" (Added screenshot)

Attached Files

jirkamat posted this 23 February 2020

I am trying Method 2 again with Flexi Layout.

Method 2: If there is nothing on the annex page that we can pre-define, create an annex document definition with blank region, this will match to every document.

I am using two FlexiLayout definitions, but it does not work as expected (even with "Use first acceptable FlexiLayout"):

The result:

btw. "Automatically when document definition is applied" is set (it is a default value).

You can keep a Required Element in your main document definitions so that id doesn't gets matched to any annex document

I don't need that I guess because I am using Header and Footer in Flexilayout which works well. My problem is that I get the leading irrelevant pages shown in the Batches view as unrecognized documents (this is without the "Empty FlexiLayout" trick):

 

 

 

Rahul Kapoor posted this 24 February 2020

In your "Empty Flexilayout" keep a Restricted Keyword(or more than one). Something that will always be there in your main document. 

By doing that, your main page will never match to the "Empty Flexilayout"

 

-Rahul Kapoor
https://www.linkedin.com/in/rahulkapoor309/

 

Close