Disabling Unsupported Protocols

  • 54 Views
  • Last Post 27 November 2018
S Harrison posted this 20 November 2018

Hello,

I am attempting to disable the following protocols in IIS:  PCT 1.0, SSL 2.0, SSL 3.0, TLS 1.0 & TLS 1.1.

These protocols are no longer supported by Microsoft, and therefore as a business we are required to disable them.

However, when I disable these protocols, FlexiCapture cannot connect to the database, and Admin Console shows the following error:  "[DBNETLIB][ConnectionOpen(SECCreateCredentials()).]SSL Security error." implying that FlexiCapture is reliant on SSL protocols to connect to the database.

I then liaised with various ABBYY representatives, both in the UK and Russia, to whom I explained the issue fully. I was then provided with an update that was meant to fix the issue, but unfortunately it did not.

Between myself and a colleague, we discovered a workaround that allowed us to disable all the protocols on the server hosting FlexiCapture, but when the protocols were disabled on the server hosting the SQL database, the same error occurred.

Although I am already in contact with technical support in pursuit of a solution, I am interested to know if anyone else has experienced a similar issue, and if so, what their solution was?

It is common for businesses to move away from unsupported software (and in this case encryption protocols), so I'm surprised that more people aren't facing the same obstacle with regards to FlexiCapture, and I'm equally surprised that this issue hasn't been resolved by ABBYY.

Any thoughts?

Ekaterina posted this 27 November 2018

Hello,

Yes, it is the regional support question. We do not have the common solution for it.

Close