FlexiCapture - Can't delete a document

  • 593 Views
  • Last Post 27 June 2017
  • Topic Is Solved
Bruno Silva posted this 22 June 2017

Hello

 

I'm trying to remove some documents out of my batch using the method DeleteDocument of IBatch.

I wrote a script to do that but everytime I'm getting a error with the message "It's not possible to modify the batch structure in this script" (the real message is in portuguese-br: Não é possível modificar a estrutura do lote neste script).

 

I tried the same script in different events handler and stages.

 

Does anybody know where it's possible to change the batch structure?

 

Here is the script

this.DeleteDocument(Page.Document);

 

Thanks.

Order By: Standard | Newest | Votes
Ekaterina posted this 23 June 2017

Hello,

Please make sure that you have written your script on the "batch processing" level.

  • Liked by
  • Bruno Silva
Bruno Silva posted this 23 June 2017

Hello Ekaterina, thanks for your reply.

 

In my automatic stage the script tab isn't appearing.

 

Thanks

Ekaterina posted this 27 June 2017

Hello,

When you create the new stage, please select “Automatic” setting without any sub-stage as shown at the screenshot. If you still can not see the “Script” tab please send us the screenshots that demonstrate the problem.

  • Liked by
  • Bruno Silva
Close