FlexiLayout and project setup: detection of PDF SampleContract, document definition has 40+ fields

  • 490 Views
  • Last Post 21 December 2018
zykuak posted this 18 December 2018

In ABBYY FlexiCapture 12, I have a PDF document with many fields being detected (40+ fields).

When I enable all the fields, it works in FlexiLayout studio, but in project setup, when I drop the PDF into hotfolder, the result is document is not detected. Let's call this document: SampleContract

 

In the document definition, if there is only 1 document (SampleContract), then the PDF document can be detected after I copy it into the hotfolder.

However if there is more than 1 document (total 5) in the doc definition, the PDF document can't be detected (it is detected as annex or unknown document type)

 

The document needs to be rotated to be the correct way up, so I have set the options under Recognition tab, in document definition properties. The following are checked:

- rotated 180 deg

- rotated 90 deg clockwise

- rotated 90 deg counterclockwise

 

In batch type properties and project properties, under image preprocessing tab,

the following are unchecked:

- use black separators to correct skew

- use black squares to correct skew

the following are checked:

- use text to correct skew

 

The settings are attached in screenshots.

 

Are there any other settings which would allow for correct detection of the document?

 

For example, under Batch type, recognition tab, I have checked the setting "use first acceptable flexilayout" - does this help if I add SampleContract as the first document in the doc definition?

 

Thanks.

 

Attached Files

Ekaterina posted this 21 December 2018

Could you please describe, what is the composition of your 5-pages file? Are there any other pages, that are not SampleContract? Are such pages first in the file? If it is so, then you get an assembly error (you have "new document for each image file" enabled, so the document is assembled, but if the first page cannot be matched with SampleContract then all others will be treated as annexes/unknown)

Please try to switch the "Document separation" to "...when Document Definition is applied" and look if it changes anything.

Close