New database created, username and temporary password not displayed. Cannot access anm console

  • 208 Views
  • Last Post 01 March 2018
mharper posted this 12 February 2018

Our IT staff created a new database for a FC12 installation but they did not receive the username and temporary password required to set up the initial admin users.

Nobody can access the admin and monitoring console. How do we figure out who was assigned the temporary password, or reset the temporary password?

Order By: Standard | Newest | Votes
Vladimir Dimitrijevic posted this 12 February 2018

Hi,

As a workaround before someone from ABBYY gives you better advice, you can manually create new user in database. Add it in table Principal, add this value to PasswordHash "428F78BF42693DA2F9F4B4BA537C5F101E275607", set password reset to 0, and IsSystemAdministrator set to 1. Add admin rights for your user to table PrincipalPermission, set Role to 10, this should be System administrator, please check before. Afterwards you can login, type your username and password: 12345678.

Best regards,
Vladimir

mharper posted this 12 February 2018

We reinstalled the application server and got the users set up, but we cannot upload projects to the application server. We also get an error message in the monitoring console that says 'Access Denied, Please login using windows account to access application server settings.' when we try to access application server settings

The error provides a link that redirects to the user login page but does not fix the problem

AlexeyEfremov posted this 01 March 2018

Hello,

I am sorry for keeping you waiting for so long.

Please check that you have exactly the same values in the dbo.Principal table (see the screenshot):

https://ibb.co/eAQuyH

and the following values in the table dbo.PrincipalPermissions for the row with PrincipalId that equals the Id of the newly created user (for me it was 13):

https://ibb.co/nG74Xc

Please try to login to FlexiCapture with

username: admin

password: 12345678

and check if you can access the database.

Please check this and let us know if this has resolved the issue.

Yours sincerely,

Alexey Efremov

Technical consultant

Close