Tables are not read correctly

  • 243 Views
  • Last Post 30 January 2018
  • Topic Is Solved
tobias1990 posted this 06 December 2017

Hello everyone,

I am currently trying to import a table. Since there is no fixed column order and the names of the columns can change, I created two tables. The first one is responsible for reading the rows, whereas the other one is used to read the column names.

My problem now is this:

As can be seen from the pictures, recognition does not work as intended. Not all columns are taken into account when reading the rows or names.

I have already adjusted every setting and have not been able to improve it. However, there are also cases where both column names and rows are correctly recognized. Has anyone already had the same problem, and does anyone know where it could be?

Best regards

Tobias

 

Attached Files

Order By: Standard | Newest | Votes
Ekaterina posted this 08 December 2017

Hello,

Please look at the available methods in the "Rows detection parameters" section in the "FlexiLayout language > Specifying element properties > Table" article in the FLS Help.

But we'd recommend to use repeating group in your case, due to better flexibility of repeating groups. Then in Document Definition Editor the repeating group can be switched to have table layout on Verification and so it will look as a table for verifiers.

tobias1990 posted this 24 January 2018

Thanks again for your help.

I have used the repeating groups and now I am faced with another problem. When I import the layout into the Process Setup Station, the table is read in, but everything is listed in a column. I tried to get to the coordinates of the individual lines by means of a script, in order to perform a division afterwards, but unfortunately I can't get this information.

is there another way to get the columns into their original form? Is it even possible to get the coordinates of an field in a script rule? 

Thank you very much

 

Ekaterina posted this 25 January 2018

Hello,

Could you please look at this topic:

http://www.capturedocs.com/thread/visualize-repeating-group-as-table/

maybe it will be helpful in your case. If our suggestion was wrong, please attach here a screenshot that will demonstrate your issue.

tobias1990 posted this 26 January 2018

Hello Ekaterina,

thanks for your fast reply. I have used two repeating groups, which are structured as follows: The first Repeating Group reads the header and the body. One table was used for this purpose. The second repeating group is responsible for the description of the individual lines. The exact structure can be found in Appendix 1.

The reason for this structure is as follows: The tables are highly variable. It can have a column length of 2-5. The column labels are also variable. The names of the individual lines are times within the table and sometimes to the left of the table. I have added screenshots 2 and 3 for a better understanding.

The import using this structure works, but in the Project Setup Station only one column is displayed to me during import, which contains the information of all imported columns (Appendix 4).

Unfortunately, the solution you are proposing does not work in this case. That's why I wanted to do the division by coordinates using a script. My goal is to restore the table to its original state in the Process Setup Studio.

Thank you

Attached Files

Ekaterina posted this 30 January 2018

Hello,

To found the cause of this behavior, the project investigation  is required. We cannot perform it in the frame of the forum. Please contact your regional support, send them sample images and your project.

  • Liked by
  • tobias1990
tobias1990 posted this 30 January 2018

Hello,

thanks for the help. That's what I'll do.

Best regards

Close