Web sevice testing

  • Last Post 18 April 2018
Антон Фио posted this 12 March 2018


I 'm using SoapUI for testing my Recognition Server Web Service.

I tried to upload file for recognition by setting LocationPath parametr in StartProcessFile method.

But had an error: "Bad Request".

When I tried to attached PDF file to my SOAP request I had error: "Unsupported Media Type".

Any help, please?


Attached Files

Order By: Standard | Newest | Votes
Ekaterina posted this 20 March 2018


Could you please send us your workflow and some samples images for reproducing the issue?

Антон Фио posted this 30 March 2018

Hello Ekaterina,

I'm using Default Workflow, local path to usual PDF file and SoapUI-5.2.1 as testing environment.

I had error using SOAP request like this:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:rec="http://www.abbyy.com/RecognitionServer4_xml/RecognitionServer4.xml">







         <rec:workflowName>Default Workflow</rec:workflowName>














Ekaterina posted this 18 April 2018


The HTTP 400 Bad Request status code indicates that the server could not understand the request because of an invalid syntax. The client should not repeat this request without changes.

 You may find the code for all the RS samples in the folder C:\Users\Public\ABBYY\ABBYY Recognition Server 4.0\Samples